Файрвол
В ModSecurity — известном WAF для Apache, IIS и nginx — нашли критическую уязвимость,